summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2016-11-30 11:29:30 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2016-12-06 20:03:35 +0530
commit835571ebcf22165135429efb0d77f11b92540ecf (patch)
tree7965939f5480fd5cae26faa8834e81bf723d9f0b /configure.ac
parente1df4321a5e362b9e9c418b1afabc2036663d66c (diff)
downloadphosphor-led-sysfs-835571ebcf22165135429efb0d77f11b92540ecf.tar.gz
phosphor-led-sysfs-835571ebcf22165135429efb0d77f11b92540ecf.zip
Add initial files for physical LED controller
This daemon uses sysfs entry for a particular LED and then triggers necessary action. Name and Path of the LED is needed as command line options to make sure this is genreric implementation. Change-Id: I3d52f1491fcb6ae8119b399a4d2c6770a3f5db30 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b38f165
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+# Initialization
+AC_PREREQ([2.69])
+AC_INIT([phosphor-led-sysfs], [1.0], [https://github.com/openbmc/phosphor-led-sysfs/issues])
+AC_LANG([C++])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+# Checks for libraries.
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+# Checks for header files.
+AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find systemd/sd-bus.h...systemd developement package required])])
+AC_CHECK_HEADER(sdbusplus/server.hpp, ,[AC_MSG_ERROR([Could not find server.hpp...openbmc/sdbusplus package required])])
+
+# Check/set gtest specific functions.
+AX_PTHREAD([GTEST_CPPFLAGS="-DGTEST_HAS_PTHREAD=1"],[GTEST_CPPFLAGS="-DGTEST_HAS_PTHREAD=0"])
+AC_SUBST(GTEST_CPPFLAGS)
+
+AC_ARG_VAR(BUSNAME, [The Dbus busname to own])
+AS_IF([test "x$BUSNAME" == "x"], [BUSNAME="xyz.openbmc_project.led.controller"])
+AC_DEFINE_UNQUOTED([BUSNAME], ["$BUSNAME"], [The Dbus busname to own])
+AC_ARG_VAR(OBJPATH, [The Ledmanager Dbus root])
+AS_IF([test "x$OBJPATH" == "x"], [OBJPATH="/xyz/openbmc_project/led/controller"])
+AC_DEFINE_UNQUOTED([OBJPATH], ["$OBJPATH"], [The Led controller Dbus root])
+
+# Create configured output
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud