summaryrefslogtreecommitdiffstats
path: root/user_channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'user_channel/Makefile.am')
-rw-r--r--user_channel/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/user_channel/Makefile.am b/user_channel/Makefile.am
index 3860a39..747c4c8 100644
--- a/user_channel/Makefile.am
+++ b/user_channel/Makefile.am
@@ -12,7 +12,12 @@ COMMON_CXX = \
-DBOOST_ASIO_DISABLE_THREADS \
-DBOOST_ALL_NO_LIB
-lib_LTLIBRARIES = libuserlayer.la libchannellayer.la
+
+lib_LTLIBRARIES =
+
+if FEATURE_LIBUSERLAYER
+
+lib_LTLIBRARIES += libuserlayer.la
libuserlayer_la_SOURCES = \
user_layer.cpp \
user_mgmt.cpp \
@@ -29,7 +34,9 @@ libuserlayer_la_LDFLAGS = \
libuserlayer_la_CXXFLAGS = \
-I$(top_srcdir) \
$(COMMON_CXX)
+endif
+lib_LTLIBRARIES += libchannellayer.la
libchannellayer_la_SOURCES = \
channel_mgmt.cpp \
channel_layer.cpp
OpenPOWER on IntegriCloud