summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cd0b64e..02583fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,12 @@ fru-read-gen.cpp: scripts/readfru.mako.cpp scripts/fru_gen.py @FRU_YAML_GEN@
$(AM_V_GEN)@FRUGEN@ -o $(top_builddir) generate-cpp
providers_LTLIBRARIES += libipmi20.la
+if FEATURE_TRANSPORT_OEM
+libipmi20_la_TRANSPORTOEM = transporthandler_oem.cpp
+else
+libipmi20_la_TRANSPORTOEM =
+endif
+
libipmi20_la_SOURCES = \
app/channel.cpp \
app/watchdog.cpp \
@@ -100,6 +106,7 @@ libipmi20_la_SOURCES = \
read_fru_data.cpp \
sensordatahandler.cpp \
user_channel/channelcommands.cpp \
+ $(libipmi20_la_TRANSPORTOEM) \
$(libipmi20_BUILT_LIST)
check_PROGRAMS =
OpenPOWER on IntegriCloud