summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 18b198c..ea44248 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,8 +5,10 @@ sbin_PROGRAMS = \
ipmid_SOURCES = \
ipmid.cpp \
- settings.cpp
-
+ settings.cpp \
+ host-cmd-manager.cpp \
+ timer.cpp \
+ utils.cpp
nodist_ipmid_SOURCES = ipmiwhitelist.cpp
BUILT_SOURCES = \
@@ -18,11 +20,9 @@ BUILT_SOURCES = \
CLEANFILES = $(BUILT_SOURCES)
#TODO - Make this path a configure option (bitbake parameter)
-ipmid_CPPFLAGS = \
- -DHOST_IPMI_LIB_PATH=\"/usr/lib/host-ipmid/\" \
- $(PHOSPHOR_LOGGING_CFLAGS) \
- $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
-
+ipmid_CPPFLAGS = -DHOST_IPMI_LIB_PATH=\"/usr/lib/host-ipmid/\" \
+ $(PHOSPHOR_LOGGING_CFLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
ipmid_LDFLAGS = \
$(SYSTEMD_LIBS) \
$(libmapper_LIBS) \
@@ -30,6 +30,7 @@ ipmid_LDFLAGS = \
$(PHOSPHOR_LOGGING_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
-export-dynamic
+
# TODO: Rather than use -export-dynamic, we should use -export-symbol to have a
# selective list of symbols.
OpenPOWER on IntegriCloud