summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 8190320..d519ba7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,12 +11,16 @@ ipmid_SOURCES = \
utils.cpp
nodist_ipmid_SOURCES = ipmiwhitelist.cpp
+libapphandler_BUILT_LIST = \
+ sensor-gen.cpp \
+ inventory-sensor-gen.cpp \
+ fru-read-gen.cpp \
+ channel-gen.cpp
+
BUILT_SOURCES = \
ipmiwhitelist.cpp \
- sensor-gen.cpp \
- inventory-sensor-gen.cpp \
- fru-read-gen.cpp \
- channel-gen.cpp
+ $(libapphandler_BUILT_LIST)
+
CLEANFILES = $(BUILT_SOURCES)
@@ -66,14 +70,12 @@ libapphandler_la_SOURCES = \
transporthandler.cpp \
globalhandler.cpp \
groupext.cpp \
- sensor-gen.cpp \
utils.cpp \
- inventory-sensor-gen.cpp \
- fru-read-gen.cpp \
selutility.cpp \
ipmi_fru_info_area.cpp \
read_fru_data.cpp \
- sensordatahandler.cpp
+ sensordatahandler.cpp \
+ $(libapphandler_BUILT_LIST)
libapphandler_la_LDFLAGS = $(SYSTEMD_LIBS) $(libmapper_LIBS) $(PHOSPHOR_LOGGING_LIBS) $(PHOSPHOR_DBUS_INTERFACES_LIBS) -lstdc++fs -version-info 0:0:0 -shared
libapphandler_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(libmapper_CFLAGS) $(PHOSPHOR_LOGGING_CFLAGS) $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
OpenPOWER on IntegriCloud