summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9bf6d4e..20af6ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,8 @@ nodist_ipmid_SOURCES = ipmiwhitelist.cpp
libipmi20_BUILT_LIST = \
sensor-gen.cpp \
inventory-sensor-gen.cpp \
- fru-read-gen.cpp
+ fru-read-gen.cpp \
+ entity-gen.cpp
BUILT_SOURCES = \
ipmiwhitelist.cpp \
@@ -70,6 +71,9 @@ inventory-sensor-gen.cpp:
fru-read-gen.cpp:
$(AM_V_GEN)@FRUGEN@ -o $(top_builddir) generate-cpp
+entity-gen.cpp:
+ $(AM_V_GEN)@ENTITYGEN@ -o $(top_builddir) generate-cpp
+
providers_LTLIBRARIES += libipmi20.la
libipmi20_la_SOURCES = \
app/channel.cpp \
OpenPOWER on IntegriCloud