summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-02-19 14:29:59 -0800
committerPatrick Venture <venture@google.com>2019-02-20 07:17:17 -0800
commit489b8f4d229877acb19a70a15afed7a1ea60b236 (patch)
tree76f4b6d2f1b493544c7857271ff85d4643571f2b /include/Makefile.am
parent87c115fa0bb1f787295bd8315a7715018fc3e377 (diff)
downloadphosphor-host-ipmid-489b8f4d229877acb19a70a15afed7a1ea60b236.tar.gz
phosphor-host-ipmid-489b8f4d229877acb19a70a15afed7a1ea60b236.zip
include: Makefile_am: force symlink creation
Force symlink creation. In the event, the daemon is being built and installed when already present, should force creation of symlinks and not fail on this case. Change-Id: Ic2cf84c36422a3be208a18a07daacfc6c587162b Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 50bb399..50f54d0 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -10,10 +10,10 @@ nobase_include_HEADERS = \
# For now they will be the same during migration
install-data-local:
$(MKDIR_P) $(DESTDIR)$(includedir)/host-ipmid
- $(LN_S) ../ipmid/iana.hpp $(DESTDIR)$(includedir)/host-ipmid/iana.hpp
- $(LN_S) ../ipmid/api.h $(DESTDIR)$(includedir)/host-ipmid/ipmid-api.h
- $(LN_S) ../ipmid/oemopenbmc.hpp $(DESTDIR)$(includedir)/host-ipmid/oemopenbmc.hpp
- $(LN_S) ../ipmid/oemrouter.hpp $(DESTDIR)$(includedir)/host-ipmid/oemrouter.hpp
- $(LN_S) ../ipmid-host/cmd.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd.hpp
- $(LN_S) ../ipmid-host/cmd-utils.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd-utils.hpp
+ $(LN_S) -f ../ipmid/iana.hpp $(DESTDIR)$(includedir)/host-ipmid/iana.hpp
+ $(LN_S) -f ../ipmid/api.h $(DESTDIR)$(includedir)/host-ipmid/ipmid-api.h
+ $(LN_S) -f ../ipmid/oemopenbmc.hpp $(DESTDIR)$(includedir)/host-ipmid/oemopenbmc.hpp
+ $(LN_S) -f ../ipmid/oemrouter.hpp $(DESTDIR)$(includedir)/host-ipmid/oemrouter.hpp
+ $(LN_S) -f ../ipmid-host/cmd.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd.hpp
+ $(LN_S) -f ../ipmid-host/cmd-utils.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd-utils.hpp
OpenPOWER on IntegriCloud