summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2018-12-14 02:14:33 -0800
committerWilliam A. Kennington III <wak@google.com>2019-02-07 01:55:40 +0000
commit194375f2676715a0e0697bab63234a4efe39fb96 (patch)
tree11282679c88b302c68996a039c9bd7016e38b53c /include/Makefile.am
parent851acb19d773fe771201968a43b7760c63757b8c (diff)
downloadphosphor-host-ipmid-194375f2676715a0e0697bab63234a4efe39fb96.tar.gz
phosphor-host-ipmid-194375f2676715a0e0697bab63234a4efe39fb96.zip
Create libipmid and libipmid-host
This starts a transition to common ipmid libraries that providers can link against. It will allow for a cleaner separation between common ipmid functionality and daemon type specific code. This is needed so we can resolve all of the symbols in the providers at link time instead of discovering bad linkage by building and running a full ipmi daemon. In future commits libraries will be packaged for libipmid and libipmid-host which provide all of the symbols used by the current set of ipmid providers. This is the first step, it just separates and renames the headers. Legacy symlinks are still kept around for compatability. It also adds stub libraries so that external users can start linking as intended. Change-Id: I6bbd7a146362012d26812a7b039d1c4075862cbd Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644
index 0000000..50bb399
--- /dev/null
+++ b/include/Makefile.am
@@ -0,0 +1,19 @@
+nobase_include_HEADERS = \
+ ipmid/api.h \
+ ipmid/iana.hpp \
+ ipmid/oemopenbmc.hpp \
+ ipmid/oemrouter.hpp \
+ ipmid-host/cmd.hpp \
+ ipmid-host/cmd-utils.hpp
+
+# Eventually we will split <ipmid/*> and <host-ipmid/*> headers
+# For now they will be the same during migration
+install-data-local:
+ $(MKDIR_P) $(DESTDIR)$(includedir)/host-ipmid
+ $(LN_S) ../ipmid/iana.hpp $(DESTDIR)$(includedir)/host-ipmid/iana.hpp
+ $(LN_S) ../ipmid/api.h $(DESTDIR)$(includedir)/host-ipmid/ipmid-api.h
+ $(LN_S) ../ipmid/oemopenbmc.hpp $(DESTDIR)$(includedir)/host-ipmid/oemopenbmc.hpp
+ $(LN_S) ../ipmid/oemrouter.hpp $(DESTDIR)$(includedir)/host-ipmid/oemrouter.hpp
+ $(LN_S) ../ipmid-host/cmd.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd.hpp
+ $(LN_S) ../ipmid-host/cmd-utils.hpp $(DESTDIR)$(includedir)/host-ipmid/ipmid-host-cmd-utils.hpp
+
OpenPOWER on IntegriCloud