summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJohnathan Mantey <johnathanx.mantey@intel.com>2019-09-16 10:50:50 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-10-24 18:10:19 +0000
commitb87034e8ce17f0fbdfcbc8aa669e0bdec987b17e (patch)
treeda02476c3273ac9e17d3e370f2b4c6c50bfb81c5 /configure.ac
parent4bbc3db633003d19bea34874e4274e701b8e3741 (diff)
downloadphosphor-host-ipmid-b87034e8ce17f0fbdfcbc8aa669e0bdec987b17e.tar.gz
phosphor-host-ipmid-b87034e8ce17f0fbdfcbc8aa669e0bdec987b17e.zip
Create framework for IPMI OEM extension commands
IPMI has four commands that accept "OEM Parameters". The existing IPMI command handlers do not account for these OEM extensions. This commit adds OEM Parameters support for the Set/Get LAN Configuration Parameters commands. Tested: ipmitool raw 0xc 1 3 0xc0 0 ;; received 0x80 return code ipmitool raw 0xc 2 3 0 0 ;; received 0x80 return code Change-Id: I81135b6d3269cec98ffd7754a03201a74c436c11 Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b759320..04c48b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,21 @@ AC_ARG_ENABLE([libuserlayer],
)
AM_CONDITIONAL(FEATURE_LIBUSERLAYER, [test "x$enable_libuserlayer" != "xno"])
+# When enable-transport-oem flag is set, the transporthandler_oem.cpp contents
+# are compiled and added to the project. The transporthandler_oem.cpp file is
+# copied from your own customization layer in the
+# phosphor-ipmi-host_%.bbappend file. It is not necessary to create this file
+# unless OEM Parameter extensions are required.
+AC_ARG_ENABLE([transport_oem],
+ [ --enable-transport-oem Enable/disable OEM Parameter extensions],
+ [case "${enableval}" in
+ yes) transport_oem=true ;;
+ no) transport_oem=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-transport_oem]) ;;
+ esac],[transport_oem=false]
+ )
+AM_CONDITIONAL([FEATURE_TRANSPORT_OEM], [test x$transport_oem = xtrue])
+
# Create configured output
AC_CONFIG_FILES([
Makefile
OpenPOWER on IntegriCloud