summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-05-31 19:34:00 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-06 19:59:09 +0000
commita6e3a3080d532536e02e304c819c1e17214e038a (patch)
tree6d3b28ba421edd669d783ced4c7b7b0d66e6d765 /configure.ac
parent1fabf229f4cc5ae3121d7fdd738f683ff5401e95 (diff)
downloadphosphor-host-ipmid-a6e3a3080d532536e02e304c819c1e17214e038a.tar.gz
phosphor-host-ipmid-a6e3a3080d532536e02e304c819c1e17214e038a.zip
Create file to indicate host requested off/reboot
Create a file to ensure the soft power off service is not run when the host is requesting a power off or reboot. There's no need to notify the host (i.e. soft power off) when they are initiating it. Change-Id: Ic9f8e7110d30f477ceae38bba9d684559d9503d3 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f534df..076cc6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,19 @@ AS_IF([test "x$enable_softoff" != "xno"],
[AC_ARG_VAR(IPMI_HOST_SHUTDOWN_COMPLETE_TIMEOUT_SECS, [Wait time until Host can quiesce])]
[AC_DEFINE_UNQUOTED([IPMI_HOST_SHUTDOWN_COMPLETE_TIMEOUT_SECS], [45*60], [Wait time until Host can quiesce])]
+
+ # Indicates an in-band power off or reboot request from the host
+ # This file is used to ensure the soft off service does not run for host
+ # initiated shutdown or reboot requests
+ [AC_ARG_VAR(HOST_INBAND_REQUEST_DIR, [Directory used to indicate the host has initiated a shutdown or reboot])]
+ AS_IF([test "x$HOST_INBAND_REQUEST_DIR" == "x"],
+ [HOST_INBAND_REQUEST_DIR="/run/openbmc/"])
+ [AC_DEFINE_UNQUOTED([HOST_INBAND_REQUEST_DIR], ["$HOST_INBAND_REQUEST_DIR"], [Directory to store host initiated shutdown file])]
+
+ [AC_ARG_VAR(HOST_INBAND_REQUEST_FILE, [File which indicates the host has initiated a shutdown or reboot])]
+ AS_IF([test "x$HOST_INBAND_REQUEST_FILE" == "x"],
+ [HOST_INBAND_REQUEST_FILE="host@%u-request"])
+ [AC_DEFINE_UNQUOTED([HOST_INBAND_REQUEST_FILE], ["$HOST_INBAND_REQUEST_FILE"], [File to create if host has initiated shutdown or reboot])]
)
# Control Host Interfaces
OpenPOWER on IntegriCloud