summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2018-10-18 15:22:43 -0700
committerWilliam A. Kennington III <wak@google.com>2018-10-18 15:22:49 -0700
commit687a43697c7e20d1185a1e27e7c58cdf13ab3472 (patch)
treed77e87241e7edff0920340269a13017489a9629e /configure.ac
parent007400c8072a97c367a6e492292f57d5d1cd5ba8 (diff)
downloadphosphor-host-ipmid-687a43697c7e20d1185a1e27e7c58cdf13ab3472.tar.gz
phosphor-host-ipmid-687a43697c7e20d1185a1e27e7c58cdf13ab3472.zip
configure: Use generic CXX compiler macro
This uses the AX_CXX_COMPILE_STDCXX() instead of AX_CXX_COMPILE_STDCXX_1{4,7}() so that the error messages we generate make slightly more sense. We get errors like: configure.ac:24: error: invalid first argument `20' to AX_CXX_COMPILE_STDCXX Instead of: ./configure: line 5132: syntax error near unexpected token `noext' ./configure: line 5132: `AX_CXX_COMPILE_STDCXX_20(noext)' Change-Id: I05512c977b8b3215a02b5d4dc6dba30ac2b83728 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b48942b..c5cd6e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@ AS_IF([test "x$enable_softoff" != "xno"],
)
# Checks for typedefs, structures, and compiler characteristics.
-AX_CXX_COMPILE_STDCXX_17([noext])
+AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CFLAGS])
AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
OpenPOWER on IntegriCloud