summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2018-01-18 10:48:37 -0600
committerTom Joseph <tomjoseph@in.ibm.com>2018-02-06 05:21:43 +0000
commit66c5fda293759e993c18812cac4620a210387dba (patch)
treece371fe2e4c24679e3a7e0abdfc303fea4ad28c7 /configure.ac
parent138e01889a4fb60c80de9b67048a959e8e671516 (diff)
downloadphosphor-host-ipmid-66c5fda293759e993c18812cac4620a210387dba.tar.gz
phosphor-host-ipmid-66c5fda293759e993c18812cac4620a210387dba.zip
DCMI: Read power value from the configured D-Bus object path
1) Parse the power_reading JSON configuration file to get the D-Bus object path for the power reading. 2) Read the power reading value from the specified D-Bus object. Change-Id: I4b9f0703318e8db2c86d0b337e524eee6da33d08 Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e124a3..ac42e1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,11 @@ AS_IF([test "x$CONTROL_HOST_OBJ_MGR" == "x"],
[CONTROL_HOST_OBJ_MGR="/xyz/openbmc_project/control"])
AC_DEFINE_UNQUOTED([CONTROL_HOST_OBJ_MGR], ["$CONTROL_HOST_OBJ_MGR"], [The Control Host D-Bus Object Manager])
+# Power reading sensor configuration file
+AC_ARG_VAR(POWER_READING_SENSOR, [Power reading sensor configuration file])
+AS_IF([test "x$POWER_READING_SENSOR" == "x"],[POWER_READING_SENSOR="/usr/share/ipmi-providers/power_reading.json"])
+AC_DEFINE_UNQUOTED([POWER_READING_SENSOR], ["$POWER_READING_SENSOR"], [Power reading sensor configuration file])
+
# Create configured output
AC_CONFIG_FILES([Makefile test/Makefile softoff/Makefile softoff/test/Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud