summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorofery <ofery@goole.com>2019-06-10 16:02:37 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-06-18 22:31:04 +0000
commit61d8dcc69736acae379e3e7ed7ecf6a85955db76 (patch)
treec15b97f6834a1517de057a1cc7b4bc9793d45d3d /configure.ac
parent0b979b61c12ffe6ab8a27acf8ad2a0165d687195 (diff)
downloadphosphor-host-ipmid-61d8dcc69736acae379e3e7ed7ecf6a85955db76.tar.gz
phosphor-host-ipmid-61d8dcc69736acae379e3e7ed7ecf6a85955db76.zip
Add an option to exclude libuserlayer from host-ipmid
Change-Id: I8e14cfd3719c7fbef739f2aa01771bc4321ce290 Signed-off-by: Ofer Yehielli <ofery@google.com> Tested: Enabled the exclude libuserlayer flag in recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend +EXTRA_OECONF_append_xxx = " --disable-libuserlayer" +HOSTIPMI_PROVIDER_LIBRARY_remove_xxx = "libusercmds.so" +NETIPMI_PROVIDER_LIBRARY_remove_xxx = "libusercmds.so" Clean build and test that userlayer.so doesn't get included in the build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e13f5e8..869c53d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,6 +192,12 @@ AC_ARG_VAR(HOST_IPMI_LIB_PATH, [The file path to search for libraries.])
AS_IF([test "x$HOST_IPMI_LIB_PATH" == "x"], [HOST_IPMI_LIB_PATH="/usr/lib/ipmid-providers/"])
AC_DEFINE_UNQUOTED([HOST_IPMI_LIB_PATH], ["$HOST_IPMI_LIB_PATH"], [The file path to search for libraries.])
+# When disable-libuserlayer flag is set, libuserlayer won't be included in the build.
+AC_ARG_ENABLE([libuserlayer],
+ AS_HELP_STRING([--disable-libuserlayer], [Set a flag to exclude libuserlayer])
+)
+AM_CONDITIONAL(FEATURE_LIBUSERLAYER, [test "x$enable_libuserlayer" != "xno"])
+
# Create configured output
AC_CONFIG_FILES([
Makefile
OpenPOWER on IntegriCloud