summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@intel.com>2018-08-01 09:16:56 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2018-08-08 17:09:05 +0000
commit28565ac3f2585b4088025833405789645e1b774f (patch)
treec59f2e108f8e655345c102a51ec40b118cd8c5f0 /configure.ac
parent0248484614a9588056916ebdaeb2b4a6b0cb9c76 (diff)
downloadphosphor-host-ipmid-28565ac3f2585b4088025833405789645e1b774f.tar.gz
phosphor-host-ipmid-28565ac3f2585b4088025833405789645e1b774f.zip
Add flags to Makefile.am to build as c++17 and header-only boost
As the project moves forward, we are updating it to use c++17 and some of the features that it offers, as well as some more boost bits. This patch makes sure that all the boost libraries are header only, adds in c++17, and makes sure that the libraries required are linked properly. Change-Id: I9a25ec971e4bf05c2c3b73e20938cf337e06077c Signed-off-by: Vernon Mauery <vernon.mauery@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 918aef7..73d63f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,7 @@ AS_IF([test "x$enable_softoff" != "xno"],
)
# Checks for typedefs, structures, and compiler characteristics.
-AX_CXX_COMPILE_STDCXX_14([noext])
+AX_CXX_COMPILE_STDCXX_17([noext])
AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CFLAGS])
AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
OpenPOWER on IntegriCloud