summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2018-12-10 15:26:19 -0800
committerPatrick Venture <venture@google.com>2018-12-11 08:48:10 -0800
commit047412cfb1d82a92d7b032bd9aa00ce48347c076 (patch)
tree3bd13b99202a92b28d6b7defde1e30afa8b336d2 /configure.ac
parent15bc9183c9c04d60a8f65db14dd19194d25e8c25 (diff)
downloadphosphor-host-ipmid-047412cfb1d82a92d7b032bd9aa00ce48347c076.tar.gz
phosphor-host-ipmid-047412cfb1d82a92d7b032bd9aa00ce48347c076.zip
configure: Fix literal usage in AS_IF
We need to make all of the contents of AS_IF literal so that they are not re-interpreted by autoconf. Change-Id: I220fa6254a16d1f59e0400a9fb1ca909a9e7befb Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 95d9ba8..407c109 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,15 +32,15 @@ PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],, [AC_M
PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,\
AC_MSG_ERROR(["Requires sdbusplus package."]))
-AS_IF([test "x$enable_softoff" != "xno"],
+AS_IF([test "x$enable_softoff" != "xno"], [
PKG_CHECK_MODULES([SDEVENTPLUS], [sdeventplus],,\
AC_MSG_ERROR(["Requires sdeventplus package."]))
# Check for sdbus++ tool
- [AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])]
+ AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
AC_MSG_ERROR([Cannot find sdbus++]))
-)
+])
# Checks for typedefs, structures, and compiler characteristics.
AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
OpenPOWER on IntegriCloud