summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2017-12-22 14:03:06 -0800
committerTom Joseph <tomjoseph@in.ibm.com>2018-01-17 15:05:57 +0000
commitc01edf283dca792d1eecedd5c03b69b7eebb6f23 (patch)
tree4fab333c768b575412a513ec59988d5f546769c8 /Makefile.am
parenta1adb0777e370103ab9f3e7f8788f74975c69897 (diff)
downloadphosphor-host-ipmid-c01edf283dca792d1eecedd5c03b69b7eebb6f23.tar.gz
phosphor-host-ipmid-c01edf283dca792d1eecedd5c03b69b7eebb6f23.zip
multiple-channel configuration via yaml
Handles converting a yaml file mapping IPMI channel to ethernet device and using this instead of a hard-coded map. Change-Id: Iedfe7cb52a2d0663b9c8a0f6f9d37fe733b63a58 Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 99808ab..8190320 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,8 @@ BUILT_SOURCES = \
ipmiwhitelist.cpp \
sensor-gen.cpp \
inventory-sensor-gen.cpp \
- fru-read-gen.cpp
+ fru-read-gen.cpp \
+ channel-gen.cpp
CLEANFILES = $(BUILT_SOURCES)
@@ -46,6 +47,9 @@ inventory-sensor-gen.cpp:
fru-read-gen.cpp:
$(AM_V_GEN)@FRUGEN@ -o $(top_builddir) generate-cpp
+channel-gen.cpp:
+ $(AM_V_GEN)@CHANNELGEN@ -o $(top_builddir) generate-cpp
+
libapphandlerdir = ${libdir}/ipmid-providers
libapphandler_LTLIBRARIES = libapphandler.la
libapphandler_la_SOURCES = \
OpenPOWER on IntegriCloud