summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJaghathiswari Rankappagounder Natarajan <jaghu@google.com>2019-02-12 13:22:55 -0800
committerJaghathiswari Rankappagounder Natarajan <jaghu@google.com>2019-02-15 21:48:56 +0000
commit9c11894eb919034fb7841520aea3f476783a85c6 (patch)
tree7d3b244ea082418317608fad7877de59bb549bb1 /Makefile.am
parent0780df105bdd00184de29f48e9946bebfc5b5fb2 (diff)
downloadphosphor-host-ipmid-9c11894eb919034fb7841520aea3f476783a85c6.tar.gz
phosphor-host-ipmid-9c11894eb919034fb7841520aea3f476783a85c6.zip
Add support for Entity Association Record
Adding support for Entity Association Record (SDR type - 0x08h) This patch includes: 1) Entity Association Record yaml file example 2) Entity Assocation Record related script and mako file changes 3) Adding Entity Association Record in get_sdr IPMI command response From the host, tested that entity association records can be fetched Change-Id: I9cf598e5d27d2e8c6751bbaae2176e7c976974b1 Tested: Yes Signed-off-by: Jaghathiswari Rankappagounder Natarajan <jaghu@google.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9bf6d4e..20af6ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,8 @@ nodist_ipmid_SOURCES = ipmiwhitelist.cpp
libipmi20_BUILT_LIST = \
sensor-gen.cpp \
inventory-sensor-gen.cpp \
- fru-read-gen.cpp
+ fru-read-gen.cpp \
+ entity-gen.cpp
BUILT_SOURCES = \
ipmiwhitelist.cpp \
@@ -70,6 +71,9 @@ inventory-sensor-gen.cpp:
fru-read-gen.cpp:
$(AM_V_GEN)@FRUGEN@ -o $(top_builddir) generate-cpp
+entity-gen.cpp:
+ $(AM_V_GEN)@ENTITYGEN@ -o $(top_builddir) generate-cpp
+
providers_LTLIBRARIES += libipmi20.la
libipmi20_la_SOURCES = \
app/channel.cpp \
OpenPOWER on IntegriCloud