summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSuryakanth Sekar <suryakanth.sekar@linux.intel.com>2019-01-16 10:37:57 +0530
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-03-26 16:38:59 +0000
commit90b00c71067df78597db92bb60dbacf654a6f80a (patch)
tree518214e15a188a194a795dc40e2cae72fceba845 /Makefile.am
parent17898f625b04d4fee6c2fd0626c47c93f2c2e7bd (diff)
downloadphosphor-host-ipmid-90b00c71067df78597db92bb60dbacf654a6f80a.tar.gz
phosphor-host-ipmid-90b00c71067df78597db92bb60dbacf654a6f80a.zip
Adding Set Password API support in Userlayer
Moved the pam function from libusercommand to libuserlayer Added the setPassword API in user layer. There are modules which requires to use set password functionality (other ipmi providers-OEM),so it's better to keep the set-password abstracted in user-layer instead of user-commands. LIBS macro hold libpam and libmapper. we want to separate the libpam from lib usercommand. so,replaced LIBS with libmapper alone. Tested:Able to set the password in ipmi using userlayer. ex: ipmitool user set password <userid> <password> user password should set properly. Change-Id: I32d55ff5c042613c89805c6b9393d18cbf880461 Signed-off-by: Suryakanth Sekar <suryakanth.sekar@linux.intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 492f452..d1ced8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,7 +126,7 @@ libusercmds_la_SOURCES = \
user_channel/usercommands.cpp
libusercmds_la_LDFLAGS = \
$(PHOSPHOR_LOGGING_LIBS) \
- $(LIBS) \
+ $(libmapper_LIBS) \
-version-info 0:0:0 -shared
libusercmds_la_CXXFLAGS = $(COMMON_CXX)
OpenPOWER on IntegriCloud