summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-07-11 18:16:50 +0530
committerPatrick Williams <patrick@stwcx.xyz>2017-08-14 18:47:08 +0000
commitac149a94543c9fae468cf45e47103998153c89a5 (patch)
tree567bf46564869edc8c346257178226934b5b31ef /Makefile.am
parent533d03b5f923e6c59ca1ffb16b6a5eb14e3f96c6 (diff)
downloadphosphor-host-ipmid-ac149a94543c9fae468cf45e47103998153c89a5.tar.gz
phosphor-host-ipmid-ac149a94543c9fae468cf45e47103998153c89a5.zip
Define the Manager for handling host bound commands
Since some of the host bound commands are valid only for OpenPower systems, a manager is needed, which can handle commands from OpenBmc common code and also OpenPower implementations. Change-Id: Icf6566e701921ecea4c8cff1c16e498385303396 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 18b198c..ea44248 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,8 +5,10 @@ sbin_PROGRAMS = \
ipmid_SOURCES = \
ipmid.cpp \
- settings.cpp
-
+ settings.cpp \
+ host-cmd-manager.cpp \
+ timer.cpp \
+ utils.cpp
nodist_ipmid_SOURCES = ipmiwhitelist.cpp
BUILT_SOURCES = \
@@ -18,11 +20,9 @@ BUILT_SOURCES = \
CLEANFILES = $(BUILT_SOURCES)
#TODO - Make this path a configure option (bitbake parameter)
-ipmid_CPPFLAGS = \
- -DHOST_IPMI_LIB_PATH=\"/usr/lib/host-ipmid/\" \
- $(PHOSPHOR_LOGGING_CFLAGS) \
- $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
-
+ipmid_CPPFLAGS = -DHOST_IPMI_LIB_PATH=\"/usr/lib/host-ipmid/\" \
+ $(PHOSPHOR_LOGGING_CFLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
ipmid_LDFLAGS = \
$(SYSTEMD_LIBS) \
$(libmapper_LIBS) \
@@ -30,6 +30,7 @@ ipmid_LDFLAGS = \
$(PHOSPHOR_LOGGING_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
-export-dynamic
+
# TODO: Rather than use -export-dynamic, we should use -export-symbol to have a
# selective list of symbols.
OpenPOWER on IntegriCloud