summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-04-03 13:31:13 -0500
committerAndrew Geissler <andrewg@us.ibm.com>2017-05-09 12:51:59 -0500
commit8315970370d63b101bd0bd579bc1f697a3c8d07c (patch)
tree856438abae898d4edd29a6df9e6ccf5e1c28aa20 /Makefile.am
parent857f54b71198dcb5a1d5acae98f0c0cb78298694 (diff)
downloadphosphor-host-ipmid-8315970370d63b101bd0bd579bc1f697a3c8d07c.tar.gz
phosphor-host-ipmid-8315970370d63b101bd0bd579bc1f697a3c8d07c.zip
Add timeout support to host control
On timeout, send error signal for all commands within the queue Change-Id: Ic995fd4b057bd83f121a3deec405a26e0991e9a2 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4daadcd..2a51d2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,8 @@ libsysintfcmds_LTLIBRARIES = libsysintfcmds.la
libsysintfcmds_la_SOURCES = \
systemintfcmds.cpp \
host-interface.cpp \
- utils.cpp
+ utils.cpp \
+ timer.cpp
libsysintfcmds_la_LDFLAGS = $(SYSTEMD_LIBS) \
$(libmapper_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
OpenPOWER on IntegriCloud