summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-04-04 14:05:09 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-04-26 12:02:26 +0530
commit4902a10c9fabcdf5e1f2868f28cba2d571d55f03 (patch)
tree9f0662ade186a796fec8bb9d69338c5e55f19b79 /configure.ac
parentaffea8bfc77162d8631b48f1eb5e79c06b96302f (diff)
downloadphosphor-gpio-monitor-4902a10c9fabcdf5e1f2868f28cba2d571d55f03.tar.gz
phosphor-gpio-monitor-4902a10c9fabcdf5e1f2868f28cba2d571d55f03.zip
Populate the file descriptor for the device
On a GPIO chip, there could be many gpio lines and for each line, there would be a corresponding input device event file. To know the assertion state of a GPIO line, a descriptor is needed. This descriptor will later be plugged into sd_event so that the GPIO state changes can be caught and handled. Change-Id: Idc8c2b429688fea2a5124b96677085b1be48128b Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7b4f75..40100c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,9 @@ AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
# For linking
LT_INIT
+# Checks for modules
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],, [AC_MSG_ERROR([Could not find phosphor-logging...openbmc/phosphor-logging package required])])
+
# Create configured output
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud