summaryrefslogtreecommitdiffstats
path: root/presence/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'presence/Makefile.am')
-rw-r--r--presence/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/presence/Makefile.am b/presence/Makefile.am
new file mode 100644
index 0000000..10a7363
--- /dev/null
+++ b/presence/Makefile.am
@@ -0,0 +1,25 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+AM_CPPFLAGS = -iquote ${top_srcdir}
+
+sbin_PROGRAMS = \
+ phosphor-fan-presence-tach
+
+phosphor_fan_presence_tach_SOURCES = \
+ fan_enclosure.cpp \
+ tach_sensor.cpp \
+ tach_detect.cpp
+nodist_phosphor_fan_presence_tach_SOURCES = \
+ fan_detect_defs.cpp
+
+phosphor_fan_presence_tach_LDADD = \
+ $(top_builddir)/libfan.la \
+ $(SDBUSPLUS_LIBS) \
+ $(PHOSPHOR_LOGGING_LIBS)
+phosphor_fan_presence_tach_CXXFLAGS = \
+ $(SDBUSPLUS_CFLAGS) \
+ $(PHOSPHOR_LOGGING_CFLAGS)
+
+BUILT_SOURCES = fan_detect_defs.cpp
+
+fan_detect_defs.cpp: ${srcdir}/gen-fan-detect-defs.py
+ $(AM_V_GEN)$(GEN_FAN_DETECT_DEFS) > $@
OpenPOWER on IntegriCloud