summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b6df27..eb6e086 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,7 @@ AC_ARG_ENABLE([cooling-type],
AM_CONDITIONAL([WANT_PRESENCE], [test "x$enable_presence" != "xno"])
AM_CONDITIONAL([WANT_CONTROL], [test "x$enable_control" != "xno"])
AM_CONDITIONAL([WANT_COOLING_TYPE], [test "x$enable_cooling-type" != "xno"])
+AM_CONDITIONAL([WANT_MONITOR], [test "x$enable_monitor" != "xno"])
# Package specific checks.
AS_IF([test "x$enable_presence" != "xno"], [
@@ -113,6 +114,9 @@ AS_IF([test "x$enable_cooling-type" != "xno"], [
[AC_MSG_ERROR([The libevdev package is required])])
AC_CONFIG_FILES([chassis-cooling-type/Makefile])
])
+AS_IF([test "x$enable_monitor" != "xno"], [
+ AC_CONFIG_FILES([monitor/Makefile])
+])
# Create configured output
AC_CONFIG_FILES([Makefile test/Makefile])
OpenPOWER on IntegriCloud