summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 8 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 6180d1e..c3dee8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,25 +1,12 @@
AM_DEFAULT_SOURCE_EXT = .cpp
-sbin_PROGRAMS = \
- phosphor-fan-presence-tach
-
-phosphor_fan_presence_tach_SOURCES = \
- fan_enclosure.cpp \
- tach_sensor.cpp \
- tach_detect.cpp \
+noinst_LTLIBRARIES = libfan.la
+libfan_la_LDFLAGS = -static
+libfan_la_LIBADD = \
+ $(SDBUSPLUS_LIBS)
+libfan_la_CXXFLAGS =
+ $(SDBUSPLUS_CFLAGS)
+libfan_la_SOURCES = \
utility.cpp
-nodist_phosphor_fan_presence_tach_SOURCES = \
- fan_detect_defs.cpp
-
-phosphor_fan_presence_tach_LDFLAGS = $(SDBUSPLUS_LIBS) $(PHOSPHOR_LOGGING_LIBS)
-phosphor_fan_presence_tach_CXXFLAGS = \
- $(SDBUSPLUS_CFLAGS) \
- $(PHOSPHOR_LOGGING_CFLAGS)
-
-BUILT_SOURCES = fan_detect_defs.cpp
-CLEANFILES = fan_detect_defs.cpp
-
-fan_detect_defs.cpp: ${srcdir}/gen-fan-detect-defs.py
- $(AM_V_GEN)$(GEN_FAN_DETECT_DEFS) > $@
-SUBDIRS = control \ No newline at end of file
+SUBDIRS = . presence control
OpenPOWER on IntegriCloud