summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 05a883d..e6df71c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,14 @@ phosphor_fan_presence_tach_SOURCES = \
fan_enclosure.cpp \
tach_sensor.cpp \
tach_detect.cpp
+nodist_phosphor_fan_presence_tach_SOURCES = \
+ fan_detect_defs.cpp
phosphor_fan_presence_tach_LDFLAGS = $(SDBUSPLUS_LIBS)
phosphor_fan_presence_tach_CXXFLAGS = $(SDBUSPLUS_CFLAGS)
+
+BUILT_SOURCES = fan_detect_defs.cpp
+CLEANFILES = fan_detect_defs.cpp
+
+fan_detect_defs.cpp: ${srcdir}/gen-fan-detect-defs.py
+ $(AM_V_GEN)$(GEN_FAN_DETECT_DEFS) > $@
OpenPOWER on IntegriCloud