summaryrefslogtreecommitdiffstats
path: root/cooling-type/Makefile.am
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2017-03-31 18:13:21 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-05-19 16:19:06 +0000
commitfef0295a8d87754e491dcf133ea927b5c4d56303 (patch)
tree625df8225e8d9681ff1b5f9afb77104c9e899946 /cooling-type/Makefile.am
parentaf5d4c5ec0e07ba7a87ddff3f2066d9b3cbb52f8 (diff)
downloadphosphor-fan-presence-fef0295a8d87754e491dcf133ea927b5c4d56303.tar.gz
phosphor-fan-presence-fef0295a8d87754e491dcf133ea927b5c4d56303.zip
Fill in shell functions/files for cooling type.
Change-Id: I8d18d3141e955adeffdd8122ebb17549c88edd77 Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
Diffstat (limited to 'cooling-type/Makefile.am')
-rw-r--r--cooling-type/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/cooling-type/Makefile.am b/cooling-type/Makefile.am
new file mode 100644
index 0000000..8be1c3e
--- /dev/null
+++ b/cooling-type/Makefile.am
@@ -0,0 +1,13 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+
+sbin_PROGRAMS = \
+ phosphor-cooling-type
+
+phosphor_cooling_type_SOURCES = \
+ main.cpp \
+ argument.cpp \
+ cooling_type.cpp
+
+phosphor_cooling_type_LDADD = $(SDBUSPLUS_LIBS)
+
+# vim: tabstop=8 noexpandtab
OpenPOWER on IntegriCloud