summaryrefslogtreecommitdiffstats
path: root/cooling-type/Makefile.am
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2017-04-06 15:05:18 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-05-19 16:19:06 +0000
commit59ae877171ef9a7df66c465c45fa89f2d1d89d38 (patch)
treebc1bb1f3367fc146247664fc41ba9b9044e85d45 /cooling-type/Makefile.am
parentfef0295a8d87754e491dcf133ea927b5c4d56303 (diff)
downloadphosphor-fan-presence-59ae877171ef9a7df66c465c45fa89f2d1d89d38.tar.gz
phosphor-fan-presence-59ae877171ef9a7df66c465c45fa89f2d1d89d38.zip
Implement updating the inventory properties
Implement code needed to update the chassis AirCooled and WaterCooled properties. Change-Id: I9a67d1129e99f841200241e2daae08fb6119d9d3 Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
Diffstat (limited to 'cooling-type/Makefile.am')
-rw-r--r--cooling-type/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/cooling-type/Makefile.am b/cooling-type/Makefile.am
index 8be1c3e..8b41812 100644
--- a/cooling-type/Makefile.am
+++ b/cooling-type/Makefile.am
@@ -1,4 +1,5 @@
AM_DEFAULT_SOURCE_EXT = .cpp
+AM_CPPFLAGS = -iquote ${top_srcdir}
sbin_PROGRAMS = \
phosphor-cooling-type
@@ -8,6 +9,13 @@ phosphor_cooling_type_SOURCES = \
argument.cpp \
cooling_type.cpp
-phosphor_cooling_type_LDADD = $(SDBUSPLUS_LIBS)
+phosphor_cooling_type_CXXFLAGS = \
+ $(SDBUSPLUS_CFLAGS) \
+ $(PHOSPHOR_LOGGING_CFLAGS)
+
+phosphor_cooling_type_LDADD = \
+ $(top_builddir)/libfan.la \
+ $(SDBUSPLUS_LIBS) \
+ $(PHOSPHOR_LOGGING_LIBS)
# vim: tabstop=8 noexpandtab
OpenPOWER on IntegriCloud