summaryrefslogtreecommitdiffstats
path: root/control/Makefile.am
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-10 14:33:35 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-04-27 10:03:54 -0500
commite2b25cb25702490e1bd8b31ce055249f0158a944 (patch)
tree73bbb10947c59aaaee41a7471499867c5e5cf78f /control/Makefile.am
parent5cfdf94fdf0ac1167c9337cec95ba4d932ad40f7 (diff)
downloadphosphor-fan-presence-e2b25cb25702490e1bd8b31ce055249f0158a944.tar.gz
phosphor-fan-presence-e2b25cb25702490e1bd8b31ce055249f0158a944.zip
Fan control: Create Fan class
This class contains the inventory name of the fan, and the sensor names representing the rotors. Calling setSpeed on this object will set the speed on all contained sensors. Change-Id: I850e2d69067813005270105618fcf69b04382b03 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'control/Makefile.am')
-rw-r--r--control/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/control/Makefile.am b/control/Makefile.am
index adfd227..56ba948 100644
--- a/control/Makefile.am
+++ b/control/Makefile.am
@@ -6,10 +6,12 @@ sbin_PROGRAMS = \
phosphor_fan_control_SOURCES = \
generated.cpp \
+ fan.cpp \
main.cpp \
manager.cpp
phosphor_fan_control_LDADD = \
+ $(top_builddir)/libfan.la \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_LOGGING_LIBS)
OpenPOWER on IntegriCloud