summaryrefslogtreecommitdiffstats
path: root/control/Makefile.am
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-12 09:51:41 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-05-04 16:01:30 +0000
commit77d32d1b0b780b9ac773bc49a6c74c19508ff8e8 (patch)
treec86bf7542d3eb1593678f77a89ffed3adaf129ab /control/Makefile.am
parent78498c941d3f0445e2c62894123e05df057258f7 (diff)
downloadphosphor-fan-presence-77d32d1b0b780b9ac773bc49a6c74c19508ff8e8.tar.gz
phosphor-fan-presence-77d32d1b0b780b9ac773bc49a6c74c19508ff8e8.zip
Fan control: Enable data generation
Start running the python script that generates the fan zone data structures during the build. If the paths to the 2 yaml files aren't provided during configure, then the yaml in the example directory will be used instead. Change-Id: I9f67c1b94b5302c30ac87b0f80746854c42776b2 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'control/Makefile.am')
-rw-r--r--control/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/control/Makefile.am b/control/Makefile.am
index fc2a2dc..04d7d96 100644
--- a/control/Makefile.am
+++ b/control/Makefile.am
@@ -5,12 +5,14 @@ sbin_PROGRAMS = \
phosphor-fan-control
phosphor_fan_control_SOURCES = \
- generated.cpp \
fan.cpp \
main.cpp \
manager.cpp \
zone.cpp
+nodist_phosphor_fan_control_SOURCES = \
+ fan_zone_defs.cpp
+
phosphor_fan_control_LDADD = \
$(top_builddir)/libfan.la \
$(SDBUSPLUS_LIBS) \
@@ -19,3 +21,8 @@ phosphor_fan_control_LDADD = \
phosphor_fan_control_CXXFLAGS = \
$(SDBUSPLUS_CFLAGS) \
$(PHOSPHOR_LOGGING_CFLAGS)
+
+BUILT_SOURCES = fan_zone_defs.cpp
+
+fan_zone_defs.cpp: ${srcdir}/gen-fan-zone-defs.py
+ $(AM_V_GEN)$(GEN_FAN_ZONE_DEFS)
OpenPOWER on IntegriCloud