summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-27 12:27:17 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-05-11 13:52:49 -0500
commite567dd24a8d943b4655ed2db74ce3639b05652bc (patch)
tree050bc3ed3a96cacaed0c1a54f80a4f110aa95093 /configure.ac
parent59c29c79ec29dc29f3a32daabe299a80d0c8a49e (diff)
downloadphosphor-fan-presence-e567dd24a8d943b4655ed2db74ce3639b05652bc.tar.gz
phosphor-fan-presence-e567dd24a8d943b4655ed2db74ce3639b05652bc.zip
phosphor-fan-monitor framework
This application will monitor the actual speeds of fans (via their sensors) and compare them to their expected speeds. If a fan is too slow for too long, it will have its Functional property in the inventory set to false. If it starts working again, the property will be set back to true. It will use configuration data to say which fans to check and which values to use for various timeout and deviation parameters. Change-Id: Ic61613018a758727835b70f2df0ecd1bf12e8256 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b6df27..eb6e086 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,7 @@ AC_ARG_ENABLE([cooling-type],
AM_CONDITIONAL([WANT_PRESENCE], [test "x$enable_presence" != "xno"])
AM_CONDITIONAL([WANT_CONTROL], [test "x$enable_control" != "xno"])
AM_CONDITIONAL([WANT_COOLING_TYPE], [test "x$enable_cooling-type" != "xno"])
+AM_CONDITIONAL([WANT_MONITOR], [test "x$enable_monitor" != "xno"])
# Package specific checks.
AS_IF([test "x$enable_presence" != "xno"], [
@@ -113,6 +114,9 @@ AS_IF([test "x$enable_cooling-type" != "xno"], [
[AC_MSG_ERROR([The libevdev package is required])])
AC_CONFIG_FILES([chassis-cooling-type/Makefile])
])
+AS_IF([test "x$enable_monitor" != "xno"], [
+ AC_CONFIG_FILES([monitor/Makefile])
+])
# Create configured output
AC_CONFIG_FILES([Makefile test/Makefile])
OpenPOWER on IntegriCloud