summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2018-09-19 11:17:09 +0800
committerLei YU <mine260309@gmail.com>2018-09-26 11:15:30 +0800
commitbd2e80a65ec3e5cc4e27c46ddcb9c0f69aa326e6 (patch)
treec1579ac297689aea898862fda75e7577bff84c50 /configure.ac
parentecd4bc7bf240b7d30ece98e74f7056b2cab1f38b (diff)
downloadphosphor-fan-presence-bd2e80a65ec3e5cc4e27c46ddcb9c0f69aa326e6.tar.gz
phosphor-fan-presence-bd2e80a65ec3e5cc4e27c46ddcb9c0f69aa326e6.zip
Fix libfan_la_CXXFLAGS
The libfan_la_CXXFLAGS was incorrectly defined as empty by a typo, fix it. Then specify gcc-ar gcc-ranlib for link time optimization, otherwise the static library will get link error. Tested: Verify the build is OK in CI, local build, and SDK build. Resolves openbmc/phosphor-fan-presence#11 Change-Id: I17c83b9927a796f8928a71688c1640d1a602a108 Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94de978..0cb53a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,10 @@ AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
AM_SILENT_RULES([yes])
+# Use gcc-ar and gcc-ranlib for static libraries built with -flto
+AC_SUBST([AR], [${ac_tool_prefix}gcc-ar])
+AC_SUBST([RANLIB], [${ac_tool_prefix}gcc-ranlib])
+
# Checks for programs.
AC_PROG_CXX
AM_PROG_AR
OpenPOWER on IntegriCloud