summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2017-01-20 13:54:59 -0600
committerMatthew Barth <msbarth@us.ibm.com>2017-01-26 10:42:10 -0600
commitae0e96c3f98e57e5988b1621ec4c67d4b27cda4f (patch)
tree98465618aca2dafe20e547f3ca42ee845f0a947e /configure.ac
parent4aa27f9bfba204d94e9f73779b0a924e2e70c1a9 (diff)
downloadphosphor-fan-presence-ae0e96c3f98e57e5988b1621ec4c67d4b27cda4f.tar.gz
phosphor-fan-presence-ae0e96c3f98e57e5988b1621ec4c67d4b27cda4f.zip
Initial fan presence build framework
Change-Id: Ic39848e285e776ef198c7a41f20debfa164af644 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ee10e62
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# Initialization
+AC_PREREQ([2.69])
+AC_INIT([phosphor-fan-presence], [1.0],
+[https://github.com/openbmc/phosphor-fan-presence/issues])
+AC_LANG([C++])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CXX
+AM_PROG_AR
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+# Checks for typedefs, structures, and compiler characteristics.
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+# Checks for libraries.
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221], ,
+[AC_MSG_ERROR([The systemd development package is required])])
+
+# Checks for library functions.
+LT_INIT # Required for systemd linking
+
+# Create configured output
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud