summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2017-05-16 13:51:10 -0500
committerMatthew Barth <msbarth@us.ibm.com>2017-05-31 11:29:45 -0500
commitd4d0f083679e6b23c4e4fe72f4958c1f313b582d (patch)
treee455ba0c6aa3c6ed729d95eb4b65d2dbc58bb3a6 /configure.ac
parent94b20f7a0fc9d42846d44579e90c60769e4e43cf (diff)
downloadphosphor-fan-presence-d4d0f083679e6b23c4e4fe72f4958c1f313b582d.tar.gz
phosphor-fan-presence-d4d0f083679e6b23c4e4fe72f4958c1f313b582d.zip
Parse set speed event groups
Adds the groups for a set speed event for each zone listed within the event. The groups are for maintaining a cached property value. Change-Id: I2de9cf62215f9861e8ea2e6807df11e6a04638fb Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e698150..4958bc2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,12 @@ AS_IF([test "x$enable_control" != "xno"], [
AC_DEFINE_UNQUOTED([FAN_ZONE_YAML_FILE], ["$FAN_ZONE_YAML_FILE"],
[The fan zone definition file to use])
+ AC_ARG_VAR(ZONE_EVENTS_YAML_FILE,
+ [The zone events definition file to use])
+ AS_IF([test "x$ZONE_EVENTS_YAML_FILE" != "x"], [
+ AC_SUBST([ZONE_EVENTS_ARG], ["-e ${ZONE_EVENTS_YAML_FILE}"])
+ ])
+
AC_ARG_VAR(FAN_ZONE_OUTPUT_DIR,
[The output directory for the generated fan zone data file])
AS_IF([test "x$FAN_ZONE_OUTPUT_DIR" == "x"],
@@ -107,6 +113,7 @@ AS_IF([test "x$enable_control" != "xno"], [
[$PYTHON ${srcdir}/control/gen-fan-zone-defs.py \
-f $FAN_DEF_YAML_FILE \
-z $FAN_ZONE_YAML_FILE \
+ $ZONE_EVENTS_ARG \
-o $FAN_ZONE_OUTPUT_DIR])
AC_CONFIG_FILES([control/Makefile])
])
OpenPOWER on IntegriCloud