summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2017-03-29 17:06:02 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-04-24 23:26:30 -0400
commitca60e10f1abd7c3d05e6a2aff62ee56e46c9debc (patch)
treea01e1d30748251596e13d06ce579526f636c3056 /configure.ac
parent93919bbdd76cd62829b4772923f998e76d871b4c (diff)
downloadphosphor-fan-presence-ca60e10f1abd7c3d05e6a2aff62ee56e46c9debc.tar.gz
phosphor-fan-presence-ca60e10f1abd7c3d05e6a2aff62ee56e46c9debc.zip
Create framework for phosphor-cooling-type app
An application called phosphor-cooling-type is being created in the phosphor-fan-presence repo under the chassis-cooling-type subdirectory. This application will update the D-Bus CoolingType properties for a cooling zone via passed in parameters. The current properties to be updated are AirCooling and WaterCooling. They will be set to true or false based the passed in parameters --air (set AirCooling to true), --water (set WaterCooling to true), and/or --gpio=<path> (path to a GPIO pin to read to determine if one or more properties should be set to true or false). Change-Id: I774065e29849aaa54653ae6188dc42aa846a1cf0 Signed-off-by: Brandon Wyman <bjwyman@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0c5300..12337c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,9 +34,12 @@ AC_ARG_ENABLE([presence],
AS_HELP_STRING([--disable-presence], [Disable fan presence package.]))
AC_ARG_ENABLE([control],
AS_HELP_STRING([--disable-control], [Disable fan control package.]))
+AC_ARG_ENABLE([cooling-type],
+ AS_HELP_STRING([--disable-cooling-type], [Disable cooling-type package.]))
AM_CONDITIONAL([WANT_PRESENCE], [test "x$enable_presence" != "xno"])
AM_CONDITIONAL([WANT_CONTROL], [test "x$enable_control" != "xno"])
+AM_CONDITIONAL([WANT_COOLING_TYPE], [test "x$enable_cooling-type" != "xno"])
# Package specific checks.
AS_IF([test "x$enable_presence" != "xno"], [
@@ -57,6 +60,12 @@ AS_IF([test "x$enable_control" != "xno"], [
AC_CONFIG_FILES([control/Makefile])
])
+AS_IF([test "x$enable_cooling-type" != "xno"], [
+ PKG_CHECK_MODULES([LIBEVDEV], [libevdev], ,
+ [AC_MSG_ERROR([The libevdev package is required])])
+ AC_CONFIG_FILES([chassis-cooling-type/Makefile])
+])
+
# Create configured output
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud