summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2017-03-29 17:06:02 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-04-24 23:26:30 -0400
commitca60e10f1abd7c3d05e6a2aff62ee56e46c9debc (patch)
treea01e1d30748251596e13d06ce579526f636c3056 /Makefile.am
parent93919bbdd76cd62829b4772923f998e76d871b4c (diff)
downloadphosphor-fan-presence-ca60e10f1abd7c3d05e6a2aff62ee56e46c9debc.tar.gz
phosphor-fan-presence-ca60e10f1abd7c3d05e6a2aff62ee56e46c9debc.zip
Create framework for phosphor-cooling-type app
An application called phosphor-cooling-type is being created in the phosphor-fan-presence repo under the chassis-cooling-type subdirectory. This application will update the D-Bus CoolingType properties for a cooling zone via passed in parameters. The current properties to be updated are AirCooling and WaterCooling. They will be set to true or false based the passed in parameters --air (set AirCooling to true), --water (set WaterCooling to true), and/or --gpio=<path> (path to a GPIO pin to read to determine if one or more properties should be set to true or false). Change-Id: I774065e29849aaa54653ae6188dc42aa846a1cf0 Signed-off-by: Brandon Wyman <bjwyman@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9baa62b..7b34537 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,3 +17,6 @@ endif
if WANT_CONTROL
SUBDIRS += control
endif
+if WANT_COOLING_TYPE
+SUBDIRS += chassis-cooling-type
+endif
OpenPOWER on IntegriCloud