summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2017-02-17 16:05:57 -0600
committerMatthew Barth <msbarth@us.ibm.com>2017-03-10 10:29:59 -0600
commit681c98db43500d34cb93739fc97e6da05450f75c (patch)
treeaf91cb5355d2a970f387f5b35de96d3bb019c3b7 /Makefile.am
parent1080b38b77998dc493fa4ce84d46008dcc53d8ba (diff)
downloadphosphor-fan-presence-681c98db43500d34cb93739fc97e6da05450f75c.tar.gz
phosphor-fan-presence-681c98db43500d34cb93739fc97e6da05450f75c.zip
Call gen-fan-detect-defs script during build
Change-Id: Ie7b9109f097490401c2f4d75f278afad6926d18b Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 05a883d..e6df71c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,14 @@ phosphor_fan_presence_tach_SOURCES = \
fan_enclosure.cpp \
tach_sensor.cpp \
tach_detect.cpp
+nodist_phosphor_fan_presence_tach_SOURCES = \
+ fan_detect_defs.cpp
phosphor_fan_presence_tach_LDFLAGS = $(SDBUSPLUS_LIBS)
phosphor_fan_presence_tach_CXXFLAGS = $(SDBUSPLUS_CFLAGS)
+
+BUILT_SOURCES = fan_detect_defs.cpp
+CLEANFILES = fan_detect_defs.cpp
+
+fan_detect_defs.cpp: ${srcdir}/gen-fan-detect-defs.py
+ $(AM_V_GEN)$(GEN_FAN_DETECT_DEFS) > $@
OpenPOWER on IntegriCloud