summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2017-02-17 15:39:36 -0600
committerMatthew Barth <msbarth@us.ibm.com>2017-03-09 15:13:33 -0600
commit293477d4650314935a3741c547efcb36d5efb340 (patch)
treea21cf9ae720be38a7d16f1a4cd33d9487dd130d9 /Makefile.am
parentae0e96c3f98e57e5988b1621ec4c67d4b27cda4f (diff)
downloadphosphor-fan-presence-293477d4650314935a3741c547efcb36d5efb340.tar.gz
phosphor-fan-presence-293477d4650314935a3741c547efcb36d5efb340.zip
Add fan presence application framework
Add class framework for detecting fans by tach Change-Id: I45295fd6bcd81c62cef36320dfbc4f0da6092557 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 74a2686..05a883d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,12 @@
AM_DEFAULT_SOURCE_EXT = .cpp
+
+sbin_PROGRAMS = \
+ phosphor-fan-presence-tach
+
+phosphor_fan_presence_tach_SOURCES = \
+ fan_enclosure.cpp \
+ tach_sensor.cpp \
+ tach_detect.cpp
+
+phosphor_fan_presence_tach_LDFLAGS = $(SDBUSPLUS_LIBS)
+phosphor_fan_presence_tach_CXXFLAGS = $(SDBUSPLUS_CFLAGS)
OpenPOWER on IntegriCloud