summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 8f3cd02..d09e678 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -201,3 +201,28 @@ callbacktest_LDADD = \
$(builddir)/../event_manager.o \
$(builddir)/../event_serialize.o \
-lstdc++fs
+
+check_PROGRAMS += interfaceaddtest
+interfaceaddtest_SOURCES = \
+ interfaceaddtest.cpp
+interfaceaddtest_CXXFLAGS = \
+ $(gtest_cflags)
+interfaceaddtest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+interfaceaddtest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += interfaceaddtest.hpp
+CLEANFILES += interfaceaddtest.hpp
+
+INTERFACEADD_TEST_GEN_DEPS = \
+ templates/interfaceaddtest.mako.hpp \
+ yaml/interfaceaddtest
+
+interfaceaddtest.hpp: $(PDMGEN) $(INTERFACEADD_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t interfaceaddtest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d ${srcdir}/yaml/interfaceaddtest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud