summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 02772e7..330bf3e 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -36,3 +36,28 @@ pathgentest.hpp: $(PDMGEN) $(PATH_TEST_GEN_DEPS)
-d yaml/pathgentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += propertygentest
+propertygentest_SOURCES = \
+ propertygentest.cpp
+propertygentest_CXXFLAGS = \
+ $(gtest_cflags)
+propertygentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+propertygentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += propertygentest.hpp
+CLEANFILES += propertygentest.hpp
+
+PROPERTY_TEST_GEN_DEPS = \
+ templates/propertygentest.mako.hpp \
+ yaml/propertygentest
+
+propertygentest.hpp: $(PROPERTY_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t propertygentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/propertygentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud