summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 893f264..324eec7 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -154,3 +154,28 @@ callbackgroupgentest.hpp: $(CALLBACKGROUP_TEST_GEN_DEPS)
-d yaml/callbackgroupgentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += conditiongentest
+conditiongentest_SOURCES = \
+ conditiongentest.cpp
+conditiongentest_CXXFLAGS = \
+ $(gtest_cflags)
+conditiongentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+conditiongentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += conditiongentest.hpp
+CLEANFILES += conditiongentest.hpp
+
+CONDITION_TEST_GEN_DEPS = \
+ templates/conditiongentest.mako.hpp \
+ yaml/conditiongentest
+
+conditiongentest.hpp: $(CONDITION_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t conditiongentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/conditiongentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud