summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index f4e2e46..893f264 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -129,3 +129,28 @@ callbackgentest.hpp: $(CALLBACK_TEST_GEN_DEPS)
-d yaml/callbackgentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += callbackgroupgentest
+callbackgroupgentest_SOURCES = \
+ callbackgroupgentest.cpp
+callbackgroupgentest_CXXFLAGS = \
+ $(gtest_cflags)
+callbackgroupgentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+callbackgroupgentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += callbackgroupgentest.hpp
+CLEANFILES += callbackgroupgentest.hpp
+
+CALLBACKGROUP_TEST_GEN_DEPS = \
+ templates/callbackgroupgentest.mako.hpp \
+ yaml/callbackgroupgentest
+
+callbackgroupgentest.hpp: $(CALLBACKGROUP_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t callbackgroupgentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/callbackgroupgentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud