summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index fe66203..f4e2e46 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -104,3 +104,28 @@ propertywatchtest_LDADD = \
${gtest_ldadd} \
${SDBUSPLUS_LIBS} \
$(builddir)/../propertywatch.o
+
+check_PROGRAMS += callbackgentest
+callbackgentest_SOURCES = \
+ callbackgentest.cpp
+callbackgentest_CXXFLAGS = \
+ $(gtest_cflags)
+callbackgentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+callbackgentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += callbackgentest.hpp
+CLEANFILES += callbackgentest.hpp
+
+CALLBACK_TEST_GEN_DEPS = \
+ templates/callbackgentest.mako.hpp \
+ yaml/callbackgentest
+
+callbackgentest.hpp: $(CALLBACK_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t callbackgentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/callbackgentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud