summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index aaae1ff..a5d7405 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -179,3 +179,15 @@ conditiongentest.hpp: $(CONDITION_TEST_GEN_DEPS)
-d ${srcdir}/yaml/conditiongentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += callbacktest
+callbacktest_SOURCES = \
+ callbacktest.cpp
+callbacktest_CXXFLAGS = \
+ $(gtest_cflags)
+callbacktest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+callbacktest_LDADD = \
+ ${gtest_ldadd} \
+ ${SDBUSPLUS_LIBS} \
+ $(builddir)/../journal.o
OpenPOWER on IntegriCloud