summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 330bf3e..fe66203 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -7,6 +7,7 @@ gtest_ldadd = -lgtest -lgtest_main -lgmock $(PTHREAD_LIBS)
TEMPLATESEARCH+=${srcdir}/templates
check_PROGRAMS =
+noinst_PROGRAMS =
BUILT_SOURCES =
CLEANFILES =
@@ -61,3 +62,45 @@ propertygentest.hpp: $(PROPERTY_TEST_GEN_DEPS)
-d yaml/propertygentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += propertywatchgentest
+propertywatchgentest_SOURCES = \
+ propertywatchgentest.cpp
+propertywatchgentest_CXXFLAGS = \
+ $(gtest_cflags)
+propertywatchgentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+propertywatchgentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += propertywatchgentest.hpp
+CLEANFILES += propertywatchgentest.hpp
+
+PROPERTY_WATCH_TEST_GEN_DEPS = \
+ templates/propertywatchgentest.mako.hpp \
+ yaml/propertywatchgentest
+
+propertywatchgentest.hpp: $(PROPERTY_WATCH_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t propertywatchgentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/propertywatchgentest \
+ -o $(builddir)/$@ \
+ generate-cpp
+
+# propertywatchtest is intentionally omitted from
+# check_PROGRAMS until a bug that manifests with
+# with GCC7 can be resolved.
+
+noinst_PROGRAMS += propertywatchtest
+propertywatchtest_SOURCES = \
+ propertywatchtest.cpp
+propertywatchtest_CXXFLAGS = \
+ $(gtest_cflags) \
+ ${SDBUSPLUS_CFLAGS}
+propertywatchtest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+propertywatchtest_LDADD = \
+ ${gtest_ldadd} \
+ ${SDBUSPLUS_LIBS} \
+ $(builddir)/../propertywatch.o
OpenPOWER on IntegriCloud