summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-09 00:23:11 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-04 22:40:30 -0400
commitc9e173f84effdfbdda9f0d5e8650644572a2d95e (patch)
treea01acde00fb4f47dcfc011290e274704d71b6c00 /src/test/Makefile.am
parente73b2c35a375af51b6c7341e9a98f9571f76b266 (diff)
downloadphosphor-dbus-monitor-c9e173f84effdfbdda9f0d5e8650644572a2d95e.tar.gz
phosphor-dbus-monitor-c9e173f84effdfbdda9f0d5e8650644572a2d95e.zip
Add testcases for property and property groups
Change-Id: I4b30d0729a704d6833c840ea08daeee961a5730b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 02772e7..330bf3e 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -36,3 +36,28 @@ pathgentest.hpp: $(PDMGEN) $(PATH_TEST_GEN_DEPS)
-d yaml/pathgentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += propertygentest
+propertygentest_SOURCES = \
+ propertygentest.cpp
+propertygentest_CXXFLAGS = \
+ $(gtest_cflags)
+propertygentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+propertygentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += propertygentest.hpp
+CLEANFILES += propertygentest.hpp
+
+PROPERTY_TEST_GEN_DEPS = \
+ templates/propertygentest.mako.hpp \
+ yaml/propertygentest
+
+propertygentest.hpp: $(PROPERTY_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t propertygentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/propertygentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud