summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-25 21:49:32 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-19 16:26:47 -0400
commit731171a12c6d52ead2d93303867b6d731d4d6728 (patch)
tree22cf0b9c7efc0bec6bfb453a573f175014a91bfe /src/test/Makefile.am
parent49e661750ceed68ada3f3ae00d6d1620800c1f5f (diff)
downloadphosphor-dbus-monitor-731171a12c6d52ead2d93303867b6d731d4d6728.tar.gz
phosphor-dbus-monitor-731171a12c6d52ead2d93303867b6d731d4d6728.zip
Add testcase for callback groups
Change-Id: Icbdc8612d73bed065227d9edfde1426206886652 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index f4e2e46..893f264 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -129,3 +129,28 @@ callbackgentest.hpp: $(CALLBACK_TEST_GEN_DEPS)
-d yaml/callbackgentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += callbackgroupgentest
+callbackgroupgentest_SOURCES = \
+ callbackgroupgentest.cpp
+callbackgroupgentest_CXXFLAGS = \
+ $(gtest_cflags)
+callbackgroupgentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+callbackgroupgentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += callbackgroupgentest.hpp
+CLEANFILES += callbackgroupgentest.hpp
+
+CALLBACKGROUP_TEST_GEN_DEPS = \
+ templates/callbackgroupgentest.mako.hpp \
+ yaml/callbackgroupgentest
+
+callbackgroupgentest.hpp: $(CALLBACKGROUP_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t callbackgroupgentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/callbackgroupgentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud