summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-31 19:43:35 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-19 16:26:48 -0400
commit2d6586a6bcfa2a97b0370dd5a6c0df18ba93641f (patch)
treede7b1708643f94ebbe6fa05a7beb516b2158aff2 /src/test/Makefile.am
parent3539db640767e6dafa652864fc5a5445db4ee697 (diff)
downloadphosphor-dbus-monitor-2d6586a6bcfa2a97b0370dd5a6c0df18ba93641f.tar.gz
phosphor-dbus-monitor-2d6586a6bcfa2a97b0370dd5a6c0df18ba93641f.zip
build: Correct out of tree build bugs
Change-Id: Id6e14414c6f15c11d1476039e3781d719f693d21 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 324eec7..aaae1ff 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -34,7 +34,7 @@ pathgentest.hpp: $(PDMGEN) $(PATH_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t pathgentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/pathgentest \
+ -d ${srcdir}/yaml/pathgentest \
-o $(builddir)/$@ \
generate-cpp
@@ -59,7 +59,7 @@ propertygentest.hpp: $(PROPERTY_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t propertygentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/propertygentest \
+ -d ${srcdir}/yaml/propertygentest \
-o $(builddir)/$@ \
generate-cpp
@@ -84,7 +84,7 @@ propertywatchgentest.hpp: $(PROPERTY_WATCH_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t propertywatchgentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/propertywatchgentest \
+ -d ${srcdir}/yaml/propertywatchgentest \
-o $(builddir)/$@ \
generate-cpp
@@ -126,7 +126,7 @@ callbackgentest.hpp: $(CALLBACK_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t callbackgentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/callbackgentest \
+ -d ${srcdir}/yaml/callbackgentest \
-o $(builddir)/$@ \
generate-cpp
@@ -151,7 +151,7 @@ callbackgroupgentest.hpp: $(CALLBACKGROUP_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t callbackgroupgentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/callbackgroupgentest \
+ -d ${srcdir}/yaml/callbackgroupgentest \
-o $(builddir)/$@ \
generate-cpp
@@ -176,6 +176,6 @@ conditiongentest.hpp: $(CONDITION_TEST_GEN_DEPS)
$(AM_V_GEN) $(PYTHON) $(PDMGEN) \
-t conditiongentest.mako.hpp \
-p "${TEMPLATESEARCH}" \
- -d yaml/conditiongentest \
+ -d ${srcdir}/yaml/conditiongentest \
-o $(builddir)/$@ \
generate-cpp
OpenPOWER on IntegriCloud