summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorGunnar Mills <gmills@us.ibm.com>2017-08-14 16:13:32 -0500
committerGunnar Mills <gmills@us.ibm.com>2017-08-21 14:26:40 +0000
commit2c11e4561c42331decf12e373c0839f40116c936 (patch)
tree2838cd1a312f0220de035eb23fd253693f7e9735 /src/test/Makefile.am
parent30474cf5daff8ce4a9fdeeaab63957673eeb9f4b (diff)
downloadphosphor-dbus-monitor-2c11e4561c42331decf12e373c0839f40116c936.tar.gz
phosphor-dbus-monitor-2c11e4561c42331decf12e373c0839f40116c936.zip
Add tests for elog
Change-Id: I58a6ac714cfa80462ab53d4487dc727e40038b06 Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index a5d7405..7dddccd 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -185,9 +185,15 @@ callbacktest_SOURCES = \
callbacktest.cpp
callbacktest_CXXFLAGS = \
$(gtest_cflags)
+ $(SDBUSPLUS_CFLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
+ $(PHOSPHOR_LOGGING_CFLAGS)
callbacktest_LDFLAGS = \
$(OESDK_TESTCASE_FLAGS)
callbacktest_LDADD = \
${gtest_ldadd} \
${SDBUSPLUS_LIBS} \
- $(builddir)/../journal.o
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS) \
+ $(PHOSPHOR_LOGGING_LIBS) \
+ $(builddir)/../journal.o \
+ $(builddir)/../elog.o
OpenPOWER on IntegriCloud