summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-31 21:34:39 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-19 16:28:06 -0400
commit18b228ee24bc6446292785cd1821d417a7c6a0c8 (patch)
treeb53da7c048db62bfcd853c6eb8a2fbf5eb6b9219 /src/test/Makefile.am
parentec2ed2fb324d92573418afcc17365c83373023ec (diff)
downloadphosphor-dbus-monitor-18b228ee24bc6446292785cd1821d417a7c6a0c8.tar.gz
phosphor-dbus-monitor-18b228ee24bc6446292785cd1821d417a7c6a0c8.zip
Invoke callbacks under make check
Add a simple test that invokes all the callbacks. There are no assertions but there is some value in ensuring the application will at least run without crashing. Change-Id: I117bff261202ae7e642094a659a954328351eac1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index aaae1ff..a5d7405 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -179,3 +179,15 @@ conditiongentest.hpp: $(CONDITION_TEST_GEN_DEPS)
-d ${srcdir}/yaml/conditiongentest \
-o $(builddir)/$@ \
generate-cpp
+
+check_PROGRAMS += callbacktest
+callbacktest_SOURCES = \
+ callbacktest.cpp
+callbacktest_CXXFLAGS = \
+ $(gtest_cflags)
+callbacktest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+callbacktest_LDADD = \
+ ${gtest_ldadd} \
+ ${SDBUSPLUS_LIBS} \
+ $(builddir)/../journal.o
OpenPOWER on IntegriCloud