summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-15 17:09:04 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-22 22:55:54 -0400
commite3a01af49b01b870dd7739bf60e7be4621754c5a (patch)
tree042405ecac4781e8921456322a99305d3fa9b6d8 /src/Makefile.am
parent34a7acdf8ef1a72586ae5d924edd4cd514c541da (diff)
downloadphosphor-dbus-monitor-e3a01af49b01b870dd7739bf60e7be4621754c5a.tar.gz
phosphor-dbus-monitor-e3a01af49b01b870dd7739bf60e7be4621754c5a.zip
pdmgen: Update script options
Add an option for specifying an alternate template for testcases. Update the output option to include the desired output filename as well as the directory. Add an option for specifying the mako template search path. Change-Id: I88634fee193409b25988eb1e7d7680aa866cc2e9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6afb7b9..fcb79e0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,4 +19,9 @@ BUILT_SOURCES = generated.cpp
CLEANFILES = generated.cpp
generated.cpp:
- $(AM_V_GEN)$(PYTHON) ${srcdir}/pdmgen.py generate-cpp -d ${srcdir}/example -o ${builddir}
+ $(AM_V_GEN)$(PYTHON) ${top_srcdir}/src/pdmgen.py \
+ -t generated.mako.cpp \
+ -p "${srcdir}" \
+ -d ${srcdir}/example \
+ -o ${builddir}/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud